Bug 37767 - Mono 4.3.2 doesn't have PCL support
Summary: Mono 4.3.2 doesn't have PCL support
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: Ms.Build ()
Version: master
Hardware: PC Mac OS
: High blocker
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
: 38215 ()
Depends on:
Blocks:
 
Reported: 2016-01-18 11:56 UTC by Alan McGovern
Modified: 2016-02-01 11:23 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alan McGovern 2016-01-18 11:56:40 UTC
Mono JIT compiler version 4.3.2 (mono-4.3.2-branch/a49236e Fri Jan 15 20:15:07 EST 2016)

Every time i try to build XS i get this error:

/Library/Frameworks/Mono.framework/Versions/4.3.2/lib/mono/4.5/Microsoft.Common.targets: error : PCL Reference Assemblies not installed.
Comment 1 Alexander Köplinger [MSFT] 2016-01-18 15:46:45 UTC
I just confirmed that the MRE doesn't include the PCLs, as we suspected on Slack. The MDK contains the PCLs.
Comment 2 Alan McGovern 2016-01-29 13:23:54 UTC
The latest 4.3.2 MDKs are definitely missing PCLs still. I'm reopening this to track the problem
Comment 3 Alan McGovern 2016-01-29 13:26:40 UTC
If you clean out your `/Library/Frameworks/Mono.framework/Versions` directory you won't be able to compile mono if you then install 4.3.2.

Example from wrench: https://gist.github.com/alanmcgovern/0b6e84d642119c75b505
Mono used: http://storage.bos.internalx.com/mono-4.3.2/f9/f9eae9f4bc9755f5c7c28c6b09b89c1ffc72b4c5/MonoFramework-MDK-4.3.2.346.macos10.xamarin.universal.pkg
Comment 4 Alexander Köplinger [MSFT] 2016-01-29 13:31:10 UTC
This is fixed, I confirmed that 4.3.2.348 contains the PCLs.
Comment 5 Alan McGovern 2016-02-01 11:23:16 UTC
*** Bug 38215 has been marked as a duplicate of this bug. ***