Bug 37679 - [Master][X.M C#/F# Unified] XM unified F# template project, getting crashed with unsupported Framework.
Summary: [Master][X.M C#/F# Unified] XM unified F# template project, getting crashed w...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Runtime ()
Version: Master
Hardware: PC Mac OS
: High major
Target Milestone: ---
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2016-01-14 08:28 UTC by Rajneesh Kumar
Modified: 2016-03-21 18:37 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Chris Hamons 2016-01-14 19:29:24 UTC
Hmm. I can't reproduce locally.

Could you rebuild the application with the additional mmp arguments sent to -v -v -v -v and attach the build log?
Comment 2 Rajneesh Kumar 2016-01-15 11:36:25 UTC
Hi Chris here is the build output:   

 https://gist.github.com/Rajneesh360Logica/26eb0957aaf2e7642bc6

Thanks..!
Comment 3 Chris Hamons 2016-01-15 15:58:23 UTC
This is likely because you have mono 4.3 installed.

However, looking at the output, we're taking System/mscorlib from XM 4.5 and other bits from the system mono. This seems rather wrong.
Comment 4 Chris Hamons 2016-01-15 15:59:56 UTC
That's because those are explicit references from the project. 

The system mono only works when our XM and the system mono are in sync. Need to decide if this is a bug or required. In any case, we need to do something.
Comment 5 Chris Hamons 2016-01-15 19:29:56 UTC
Fixed in a732539359c21aecc24e7dcf5ebdba776e03c031. 

Good catch!
Comment 6 Rajneesh Kumar 2016-01-18 18:31:27 UTC
I have checked this issue with the following latest master build:
xamarin.mac-2.7.0.48_7c5d70e24e5ae18c97c3d3f46c2db6c209af3af9

I observed that after setting target framework to Unsupported framework, application launch successfully.

Screencast: http://www.screencast.com/t/JCNcaIKS

This issue has been fixe in master build, I will Re-Verify this issue when it will merged in release build.

Environment Info: https://gist.github.com/Rajneesh360Logica/81e9dace05e617b59370

Thanks..!