Bug 37601 - [WinPhone] ToolbarItem throws error when navigating to TabbedPage
Summary: [WinPhone] ToolbarItem throws error when navigating to TabbedPage
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.0.0
Hardware: PC Windows
: Normal major
Target Milestone: ---
Assignee: E.Z. Hart [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-01-12 04:55 UTC by Adam
Modified: 2016-04-15 18:51 UTC (History)
9 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Reproduction (387.85 KB, application/x-zip-compressed)
2016-01-12 04:55 UTC, Adam
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Adam 2016-01-12 04:55:55 UTC
Created attachment 14548 [details]
Reproduction

Finally reproduced this crazy bug. If you have a ToolbarItem and then navigate to a TabbedPage, it will throw an Object not set to an instance of an object error.

If you navigate to a regular ContentPage or remove the ToolbarItem, then no error is thrown.

Reproduction attached.
Comment 1 Adam 2016-01-12 04:57:58 UTC
Just to note, the ToolbarItem isn't actually causing the navigation, its any navigation from any VisualElement to the TabbedPage.
Comment 2 Jimmy [MSFT] 2016-01-25 22:29:21 UTC
I tested with previous versions of Forms and this seems to be a regression introduced in 1.5.2.6477-pre2.
Comment 3 Development Consolit 2016-03-03 16:06:52 UTC
Any sign of a fix yet?
Comment 4 E.Z. Hart [MSFT] 2016-03-03 19:56:12 UTC
Fix has been submitted and should be included in an upcoming release.