Bug 37574 - man pages aren't available in El Capitan
Summary: man pages aren't available in El Capitan
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Installers
Classification: Mono
Component: General ()
Version: 4.2.0 (C6)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Alexis Christoforides
URL:
Depends on:
Blocks:
 
Reported: 2016-01-11 13:31 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2016-12-15 19:22 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Rolf Bjarne Kvinge [MSFT] 2016-01-11 13:31:04 UTC
Repro:

> man mono
No manual entry for mono

This seems to be because there are no mono man pages in /usr/local/share/man.
Comment 1 Rodrigo Kumpera 2016-01-11 15:41:53 UTC
Hey Alexis,

Could you verify what's going on here?
Comment 2 Andi McClure 2016-12-15 19:21:18 UTC
Rolf, we can't reproduce this-- as far as we can tell man is able to find the manpage installed in /Library/Frameworks/Mono.frameworks along with the mono executable. Are you still seeing this, and how did you install your mono?
Comment 3 Rolf Bjarne Kvinge [MSFT] 2016-12-15 19:22:36 UTC
It works for me know, and I don't remember how I did this :(