Bug 3755 - NUnit unit test debugging ignores do not step into framework setting
Summary: NUnit unit test debugging ignores do not step into framework setting
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-03-05 11:47 UTC by Csaba Halász
Modified: 2012-03-06 03:15 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test solution (1.28 KB, application/x-compressed)
2012-03-05 11:47 UTC, Csaba Halász
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Csaba Halász 2012-03-05 11:47:18 UTC
Created attachment 1462 [details]
test solution

When debugging a nunit test, the debugger steps into framework code even though the "do not step into framework code" option is enabled.

How to reproduce (see attachment):
1) open the solution ;)
2) open Test.cs
3) put breakpoint in the "Run" method (line 12)
4) build the solution (F8)
5) make sure the "debug project code only; do not step into framework code" option in the preferences is ticked
6) switch to "unit testing" view
7) right click on the root item
8) select "Run test with"
9) select "Mono Soft Debugger"
10) when stopped at the breakpoint, use "step into" (F11)

At this point, the debugger steps into TimeSpan.cs framework code.
Doing a similar test with a normal executable, the setting is honored.

MonoDevelop version is 2.8.8.0 RC3, mono is 2.10.8.1
Comment 1 Jeffrey Stedfast 2012-03-05 13:43:57 UTC
the NUnit test runner isn't properly setting the user assembly list
Comment 2 Mike Krüger 2012-03-06 03:15:47 UTC
Should work now.

@Jeffrey: The API didn't support it - I just added a parameter to handle that case, but it's not really a good & clean solution.