Bug 37510 - Problem handling leading decimal point in .NET 2.0 VB app
Summary: Problem handling leading decimal point in .NET 2.0 VB app
Status: RESOLVED ANSWERED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: 3.2.x
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-01-08 05:42 UTC by jhansonxi
Modified: 2016-01-11 08:59 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description jhansonxi 2016-01-08 05:42:57 UTC
Xubuntu 14.04 x86_64
wine 1.8
wine-mono 4.5.6

Mono 3.2.8 packages from Ubuntu repos (I think these are the important ones):
mono-runtime: 3.2.8+dfsg-4ubuntu1.1
mono-vbnc: 3.0~pre20130627.4dcc70f-1
libmono2.0-cil: 3.2.8+dfsg-4ubuntu1.1 

Wire Gauge v3
http://www.ultracad.com/wg.calc.htm

App generates a divide by zero error if a value begins with a decimal point.  Works normally if a zero precedes the decimal point.

Steps to reproduce:
1. Start WireGauge3.exe
2. Select the Metric radio button.
3. Wire Gauge: (empty)
4. Trace Weight: 2
5. Trace Width: .2
6. Click the Wire Gauge Solve button.

I receive a "Divide by zero. Please check data!" error dialog.  If I enter "0.2" for the Trace Width, the Wire Gauge box computes "35.82".  This occurs with both mono running on Wine (wine-mono 4.5.6) and Linux mono from Ubuntu repos.  Leading zero is not required when using Wine and .Net 2 runtime (winetricks dotnet20).
Comment 1 Marek Safar 2016-01-11 08:59:02 UTC
Please update to recent Mono 4.2 or newer which should have this sort of errors resolved.