Bug 37509 - Unable to find a version of 'Xamarin.Forms' that is compatible with 'Xamarin.Android.Support.v4 23.1.1.0'.
Summary: Unable to find a version of 'Xamarin.Forms' that is compatible with 'Xamarin....
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-01-08 03:40 UTC by Cody Beyer (MSFT)
Modified: 2016-02-25 20:35 UTC (History)
4 users (show)

Tags: Papercut ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Cody Beyer (MSFT) 2016-01-08 03:40:46 UTC
### Description

Updating Xamarin.Android.Support et al via NuGet while using Xamarin.Forms 2.x in an Android project will cause the following error to appear:

Unable to find a version of 'Xamarin.Forms' that is compatible with 'Xamarin.Android.Support.v4 23.1.1.0'.

### Steps to Reproduce

1. Create Xamarin.Forms app
2. Update to Xamarin.Forms 2.x
3. Attempt to upgrade Xamarin.Android.Support.v4 23.1.1

### Expected Results

Upgrade to Xamarin.Android.Support.v4 23.1.1 occurs

### Actual Results

Above error occurs

### Versions

=== Xamarin Studio ===

Version 5.10.1 (build 6)
Installation UUID: 1dc08d38-68d9-48c0-a80c-2cc1069f9299
Runtime:
	Mono 4.2.1 (explicit/6dd2d0d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010102

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.2 (9548)
Build 7C68

=== Xamarin.iOS ===

Version: 9.4.0.0 (Business Edition)
Hash: 7322991
Branch: master
Build date: 2015-12-08 16:20:29-0500

=== Xamarin.Android ===

Version: 6.0.0.34 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Xamarin.Mac ===

Version: 2.4.0.109 (Business Edition)

=== Build Information ===

Release ID: 510010006
Git revision: 0b60eecdb531933734519c13257d16a780274aab
Build date: 2015-12-04 20:28:20-05
Xamarin addins: 9876fd7c9837977178411ec7375b4352c0a0d6af
Build lane: monodevelop-lion-cycle6-baseline

=== Operating System ===

Mac OS X 10.11.2
Darwin Beyer-Mac.local 15.2.0 Darwin Kernel Version 15.2.0
    Fri Nov 13 19:56:56 PST 2015
    root:xnu-3248.20.55~2/RELEASE_X86_64 x86_64
Comment 1 Cody Beyer (MSFT) 2016-01-08 03:44:17 UTC
### Workaround

1: Remove all packages from Android App (including Forms)
2. Add Xamarin.Forms from NuGet
 
The act of adding Xamarin.Forms from NuGet will retrieve the correct versions of the various Android support libraries, including those that are throwing the error
Comment 2 Peter Collins 2016-01-27 21:00:39 UTC
This is by design. Any given Forms package has both a minimum and maximum version of Android.Support.* (and GooglePlayServices.*) that it supports. New versions of support library bindings have resulted in breakages in Forms in the past. As a result, this was the best solution decided on at the time to ensure new versions of support bindings could be released when ready, while ensuring Forms users would be prevented from upgrading to a version that might break their project.
Comment 3 ramesh.sringeri 2016-02-19 14:17:51 UTC
Unfortunately removing and trying to add Xamarin.Forms from Nuget does not resolve this. 

Nuget lists Xamarin.Forms 2.0.1.6505 depends on 23.0.1.3 of 

Xamarin.Android.Support.v4
Xamarin.Android.Support.Design
Xamarin.Android.Support.v7.AppCompat
Xamarin.Android.Support.v7.CardView
Xamarin.Android.Support.v7.MediaRouter

However Nuget has 23.1.1.0 

Any other workarounds?
Comment 4 ramesh.sringeri 2016-02-19 14:24:12 UTC
The workaround is to add-remove-add-remove-add until it works. I had to try 3 times.
Comment 5 ahmed 2016-02-25 20:35:46 UTC
I tried this workaround 3 times and it didn't work for me. Do I need to dance around in  a circle too? would like to resolve this issue since I want to use a cross platform progress/loader bar plugin in my Xamarin.Forms project -see github issue



https://github.com/aritchie/userdialogs/issues/130