Bug 37480 - KeePass software : After search, Auto-type does not work : The object was used after being disposed
Summary: KeePass software : After search, Auto-type does not work : The object was use...
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: 4.0.0
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-01-07 16:46 UTC by Damien Gombault
Modified: 2016-01-09 13:07 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Damien Gombault 2016-01-07 16:46:30 UTC
Hi.

I reported a bug on KeePass bug tracker (.NET password management software) :
http://sourceforge.net/p/keepass/bugs/1461/

KeePass developpers say it's a Mono bug :

After search, Auto-Type feature does not work anymore.
KeePass displays an error window : The object was used after being disposed

How to reproduced it (on Linux with Mono) :
- Launch KeePass
- Use Edit → Find menu (or Ctrl+F)
- Search for something
- Results are displayed
- Use Auto-Type feature
- Error : The object was used after being disposed

A similar bug was previously created : http://sourceforge.net/p/keepass/bugs/1226/
This bug was closed as a duplicate of bug : https://sourceforge.net/p/keepass/bugs/1232/
I have reproduced this bug recently on Archlinux and Fedora 23.
Downstream bug report : https://bugzilla.redhat.com/show_bug.cgi?id=1296563

Package used :
keepass-2.30-4.fc23.x86_64
mono-core-4.0.5-3.fc23.x86_64

On Archlinux, I tried with Mono 4.2.
I have the same problem but a different error message.
Comment 1 Zoltan Varga 2016-01-09 13:07:04 UTC
KeePass is based on windows.forms, which is no longer supported in mono, so this problem is unlikely to be fixed.