Bug 37322 - [C6SR1 alpha] Drop-down list of simulator or real devices not filled
Summary: [C6SR1 alpha] Drop-down list of simulator or real devices not filled
Status: CLOSED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: 4.1.0 (C7)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-29 16:12 UTC by softlion
Modified: 2017-03-07 00:27 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED NOT_REPRODUCIBLE

Description softlion 2015-12-29 16:12:01 UTC
After VS succesfully connects to the build host, sometime (70% chance) the dropdown list stays empty.
If you wait a minute or two, it may fill (or not).

If it does not fill, most of the time, a simple workaround is to kill the mac service IDB.exe (one or multiple times) until this dropdown list fills by itself.

If this workaround does not work, closing visual studio, waiting for all Xamarin mac services to shutdown (ps -eax | grep Xamarin), and restarting VS also fix the issue.

Last option: reboot the mac and the pc.


This also happens when the pc wakes up, after it went to sleep.
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2016-03-01 23:21:04 UTC
## Note to the Xamarin engineering team

At first glance it appears this issue might have the same underlying cause as Bug 37613 (Bug 38695).
Comment 2 Emanuel 2016-05-11 18:49:34 UTC
We couldn't reproduce this issue so I'll change it to resolved. 
If you're still able to reproduce it with the latest beta version (4.1), please reopen this bug.
Comment 3 Rajneesh Kumar 2016-05-20 15:14:40 UTC
I am also no longer able to reproduce this issue. I am getting drop-down list of simulator and real devices properly.

So as of now I am closing this issue. If anyone face this issue so feel free to reopen it or file a seperate issue.

Thanks..!
Comment 4 Eric Maupin 2017-03-06 22:41:58 UTC
This still happens fairly often, after connecting the simulator list does not populate.
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2017-03-07 00:24:18 UTC
This exact bug report can be considered closed at this time since (a) it has been marked as resolved for a bit over 9 months, (b) the fixes for the bugs mentioned in Comment 1 might have resolved a number of the precise symptoms as originally reported in Comment 0, and (c) there have been many code changes since the original report.  For any appearances of similar issues in more recent version, please file new bug reports and be sure to include as many details [1] as possible.  A new bug report will have the added advantage that the discussion can focus on the issue as experienced by the most recent user hitting the issue.  Thanks in advance!

[1] https://developer.xamarin.com/guides/cross-platform/troubleshooting/questions/howto-file-bug/