Bug 37295 - Windows 10 Preview ListView control doesn't show Detail
Summary: Windows 10 Preview ListView control doesn't show Detail
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.0.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: E.Z. Hart [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-12-27 16:36 UTC by colinpbriggs@live.com.au
Modified: 2016-01-20 21:00 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description colinpbriggs@live.com.au 2015-12-27 16:36:19 UTC
Xamarin Forms App V2.0 for Android, iOS, WinPhone and Windows 10 UWP using PCL
Xamarin.Forms NuGet V2.0.0.6490

ListView control on iOS, Android and winPhone all show Text and Detail lines OK. On Windows 10 UWP the Detail line does not show.

Issue happens on Windows 10 PC V1511 (build 11082.1000) and on Windows 10 Phone V1511 (build 10.0.10587.36)

Sample code is below. Detail="{Binding DescriptionSecondary}" is never shown.

Regards Colin...

<?xml version="1.0" encoding="utf-8" ?>
<ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
             xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
             xmlns:uc="clr-namespace:HTHPdt.Controls;assembly=HTHPdt"
             x:Class="HTHPdt.DocumentsPage" >

  <ContentPage.ToolbarItems>
    <ToolbarItem x:Name="AddDocument" Text="Add" Order="Primary" Command="{Binding AddDocumentCommand}">
      <ToolbarItem.Icon>
        <OnPlatform x:TypeArguments="FileImageSource" WinPhone="Assets/add.png" />
      </ToolbarItem.Icon>
    </ToolbarItem>
  </ContentPage.ToolbarItems>

  <StackLayout>
    <Label Text="{Binding Title}" FontSize="Large" HorizontalOptions="Center"/>
    <SearchBar x:Name="Filter" Placeholder="Filter files"/>

    <ListView x:Name="DocumentsList" ItemsSource="{Binding Documents}" VerticalOptions="FillAndExpand">
      <ListView.ItemTemplate>
        <DataTemplate >
          <TextCell Text="{Binding DescriptionPrimary}" Detail="{Binding DescriptionSecondary}"  >
            <TextCell.ContextActions>
              <MenuItem Clicked="OnDelete" CommandParameter="{Binding .}"
               Text="Delete" IsDestructive="True" />
            </TextCell.ContextActions>
          </TextCell>
        </DataTemplate>
      </ListView.ItemTemplate>
    </ListView>

    <StackLayout Orientation="Horizontal" >
      <uc:ToggleButton x:Name="SortSequence" ItemsSource="{Binding SortSequences}" Text="{Binding Sequence, Mode=OneWayToSource}" HorizontalOptions="StartAndExpand" Command="{Binding SortDocumentsCommand}"/>
      <uc:ToggleButton x:Name="SortDirection" ItemsSource="{Binding SortDirections}" Text="{Binding Direction, Mode=OneWayToSource}" HorizontalOptions="EndAndExpand" Command="{Binding SortDocumentsCommand}"/>
    </StackLayout>
  </StackLayout>
</ContentPage>
Comment 2 E.Z. Hart [MSFT] 2016-01-20 21:00:29 UTC
Fixed in 2.1.0-pre1