Bug 37270 - [Forms:Android] ListView grouping not working with CachingStrategy=RecycleElement
Summary: [Forms:Android] ListView grouping not working with CachingStrategy=RecycleEle...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: Other Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-23 19:58 UTC by Alex Rainman
Modified: 2016-03-23 21:12 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alex Rainman 2015-12-23 19:58:09 UTC
GroupHeaderTemplate bindings go crazy on scrolling.
Comment 1 Paul DiPietro [MSFT] 2015-12-24 04:21:19 UTC
A reproduction project would be appreciated in helping to investigate the issue.
Comment 2 FieldstrikeMobile 2016-02-23 10:12:46 UTC
I have also found this issue.

The problem here is if your list is originally grouped (this works fine)

Then set the isgrouped property to false so the list is now not grouped.

The old group headers stay in place due to recycling element

I will try to get a repo together when I can
Comment 3 FieldstrikeMobile 2016-02-23 12:03:35 UTC
@AlexRainman Does this bug https://bugzilla.xamarin.com/show_bug.cgi?id=39039 describe what you are seeing?
Comment 4 Chris King 2016-03-16 16:07:29 UTC
Resolved fix as duplicate of 39039. Thank you for your submission! 

Warm regards, XFT
Comment 5 Alex Rainman 2016-03-16 16:10:25 UTC
Yes, it looks the same but in ma case even the cells where getting weird with no background color for example.