Bug 37266 - Downgrading from Xamarin.Mac 2.4.* to Xamarin.Mac 2.0.2 create issue MMP file not found
Summary: Downgrading from Xamarin.Mac 2.4.* to Xamarin.Mac 2.0.2 create issue MMP file...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: mmp ()
Version: 2.0.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-12-23 15:16 UTC by KAMAL
Modified: 2015-12-23 18:06 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description KAMAL 2015-12-23 15:16:58 UTC
Hi All,

I am working on Xamarin.Mac application. Its working fine with following configuration
OSX 10.11
Xamarin.Studio 5.10.1
Xamarin.Mac 2.4.*

but when i downgraded xamarin.mac to 2.0.2 it create issue MMp file not found with following Build Output:

MMP: error MM0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
		System.IO.DirectoryNotFoundException: Directory '/Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs' not found.
		  at System.IO.Directory.ValidateDirectoryListing (System.String path, System.String searchPattern, System.Boolean& stop) [0x00000] in <filename unknown>:0 
		  at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000] in <filename unknown>:0 
		  at System.IO.Directory.GetDirectories (System.String path, System.String searchPattern) [0x00000] in <filename unknown>:0 
		  at System.IO.Directory.GetDirectories (System.String path) [0x00000] in <filename unknown>:0 
		  at MonoMac.Bundler.Driver.SetSDKVersion () [0x00000] in <filename unknown>:0 
		  at MonoMac.Bundler.Driver.Compile (IEnumerable`1 internalSymbols) [0x00000] in <filename unknown>:0 
		  at MonoMac.Bundler.Driver.Pack (IList`1 unprocessed) [0x00000] in <filename unknown>:0 
		  at MonoMac.Bundler.Driver.Main2 (System.String[] args) [0x00000] in <filename unknown>:0 
		  at MonoMac.Bundler.Driver.Main (System.String[] args) [0x00000] in <filename unknown>:0 
	Task "Mmp" execution -- FAILED
	Done building target "_CompileToNative" in project "/Users/akhil/Desktop/Projects/Uploader/MacUploaderMono/Applications/Uploader/Uploader.csproj".-- FAILED
	
Done building project "/Users/akhil/Desktop/Projects/Uploader/MacUploaderMono/Applications/Uploader/Uploader.csproj".-- FAILED

Build FAILED.
Comment 1 KAMAL 2015-12-23 18:06:57 UTC
Hi All,

The above mentioned issue is resolved.

To resolve this issue run following command on terminal

sudo ln -s /Applications/Xcode7.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk /Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs