Bug 37257 - [ppdb] Assertion "debug-mono-ppdb.c:294, condition `method->token' not met"
Summary: [ppdb] Assertion "debug-mono-ppdb.c:294, condition `method->token' not met"
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Alexander Kyte
URL:
Depends on:
Blocks:
 
Reported: 2015-12-23 07:31 UTC by David Karlaš
Modified: 2016-01-03 06:13 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro project (23.50 KB, application/zip)
2015-12-23 22:12 UTC, David Karlaš
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description David Karlaš 2015-12-23 07:31:16 UTC
https://gist.github.com/DavidKarlas/3b2898537e19f2bb4ec2

Mono version: Mono 4.3.2 (master/44a04d5 Tue Dec 22 16:11:50 EST 2015) (64-bit)
Comment 1 David Karlaš 2015-12-23 22:12:16 UTC
Created attachment 14398 [details]
repro project

No need for roslyn/compiling cpPdbBug.exe/.pdb is already in bin/Debug folder just run, it will crash...
Comment 2 David Karlaš 2015-12-24 13:12:35 UTC
Not sure if this is same or sperate bug but I'm getting crashes also with .mdb: https://gist.github.com/DavidKarlas/dbffab1866e9cd5aaa8c 
https://gist.github.com/DavidKarlas/6357b096b1c5a16c6fd5
Comment 3 Zoltan Varga 2016-01-02 04:29:20 UTC
@kyte: this is fixed now right ?
Comment 4 Alexander Kyte 2016-01-03 06:12:51 UTC
Yes it should be.