Bug 37134 - Inspector doesn't work for WPF in 64bit mode
Summary: Inspector doesn't work for WPF in 64bit mode
Status: RESOLVED FIXED
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Agent: WPF ()
Version: 0.3.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: inspectordev-discuss
URL:
Depends on:
Blocks:
 
Reported: 2015-12-18 05:09 UTC by Egorbo
Modified: 2016-04-12 23:56 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Egorbo 2015-12-18 05:09:23 UTC
Steps to reproduce: 
1) Create a simple WPF application
2) Make sure Inspector works for it (as it uses x86 by default even in 64bit Windows)
3) Switch to x64 bit in the project properties
4) Press "Inspect current app" - nothing happens

the only line in the log - "Inspector extension loaded".

VS Community Edition Update 1 (v. 14.0.24720.00)
Inspector - 0.3.2.73
Windows 10 64bit
Comment 1 Sandy Armstrong [MSFT] 2016-04-12 23:56:34 UTC
This will be fixed in 0.7.2.