Bug 3713 - Pressing cmd-enter while debugger is running sometimes rebuilds the solution
Summary: Pressing cmd-enter while debugger is running sometimes rebuilds the solution
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: Trunk
Hardware: PC Mac OS
: --- major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-03-02 05:23 UTC by Alan McGovern
Modified: 2012-03-09 13:11 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alan McGovern 2012-03-02 05:23:39 UTC
I believe this bug is triggered by pressing cmd-enter while the debugger is not paused at a breakpoint. It is very annoying.
Comment 1 Jeffrey Stedfast 2012-03-02 21:10:59 UTC
Can you step through the Debug command handler and figure out what is going on?

I can't reproduce this.
Comment 2 Alan McGovern 2012-03-09 09:21:43 UTC
http://screencast.com/t/xUU74qowvNhh
Comment 3 Jeffrey Stedfast 2012-03-09 13:11:17 UTC
Fixed the menu to not enable the Continue command if it isn't in the paused state.