Bug 37127 - Custom Renderer Still Causes the Original Element to Be Rendered
Summary: Custom Renderer Still Causes the Original Element to Be Rendered
Status: RESOLVED INVALID
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-17 18:41 UTC by Jimmy [MSFT]
Modified: 2015-12-17 19:23 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro project (54.66 KB, application/zip)
2015-12-17 18:41 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Jimmy [MSFT] 2015-12-17 18:41:32 UTC
Created attachment 14341 [details]
repro project

### Overview
Using a custom ContentView with its content set, if you inflate a native axml layout and set that as the native control inside the custom renderer, the ContentView’s original content is still also rendered above the native layout. 


### Steps to Reproduce
1. Run the attached Android project


### Expected Results
Only the layout defined in the axml file is displayed. There should be three TextViews followed by a button all inside a blue LinearLayout.


### Actual Results
Both the native elements and Forms elements are rendered.


### Environment Info
Test with Forms 2.0
Comment 1 Jason Smith [MSFT] 2015-12-17 19:01:34 UTC
This is expected behavior. Use a View class instead of ContentView with content you dont expect to display.