Bug 37126 - ListView with custom ItemTemplateSelector not updating Background binding in ViewCell
Summary: ListView with custom ItemTemplateSelector not updating Background binding in ...
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-17 17:59 UTC by Steve Hatch
Modified: 2017-05-09 13:01 UTC (History)
9 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
sample project to show ListView binding error (433.42 KB, application/zip)
2015-12-17 17:59 UTC, Steve Hatch
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 37126 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Steve Hatch 2015-12-17 17:59:23 UTC
Created attachment 14340 [details]
sample project to show ListView binding error

I have a custom ListView that implements a ItemTemplateSelector.  Once the ObservalbleCollection is cleared and loaded with new items the Background property stops working randomly.

I have attached a sample project that exhibits this behavior.  All it does is load up a collection with ViewModels (randomly assigning color attributes to them) and the ItemTemplateSelector selects the correct template based on the type (for this example there is only one type)

When you run it you'll see that they are all correct but when you tap any button which causes the collection to be cleared and reloaded with new items, some of the bindings are now messed up.  It's like the ListView is holding onto some of the previous bindings and not updating them with the new items data.
Comment 1 Steve Hatch 2015-12-17 18:00:58 UTC
This exact sample code works perfect on iOS
Comment 2 Steve Hatch 2015-12-17 18:01:45 UTC
This bug is holding up the release of our product, please expedite if possible
Comment 3 Steve Hatch 2015-12-31 19:49:08 UTC
As I indicated nearly two weeks ago, this defect is holding up the release of our product.  I have provided a example the exhibits the bug.  What else do I need to do to escalate this defect?
Comment 5 Jeffrey Dobos 2016-01-13 13:45:40 UTC
This bug was confirmed a week ago.  Please provide status.  If it cannot be fixed we need to know now in order to create an alternative design.
Comment 7 Steve Hatch 2016-01-14 03:18:43 UTC
Joe- Can you tell me Xamarin's status on addressing this defect?  We have a completed product but cannot release it due to this problem.  Our client is going more impatient by the day.  We really need to know if the time to fix is days or weeks at this point.
Comment 8 Joe Sauve 2016-01-14 03:59:22 UTC
@Steve Hatch: I personally have no status on this. Just reporting that I too am experiencing the same issue.