Bug 371 - Exceptions on release build for device with MonoTouch 4.1
Summary: Exceptions on release build for device with MonoTouch 4.1
Status: RESOLVED DUPLICATE of bug 346
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 4.x
Hardware: Macintosh Mac OS
: --- blocker
Target Milestone: Untriaged
Assignee: monotouch@xamarin.com
URL:
Depends on:
Blocks:
 
Reported: 2011-08-23 16:27 UTC by Ken Budris
Modified: 2011-08-24 08:23 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
stack trace output (125.47 KB, application/msword)
2011-08-23 16:27 UTC, Ken Budris
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 346

Description Ken Budris 2011-08-23 16:27:54 UTC
Created attachment 171 [details]
stack trace output

I have two different apps that were building ok with MT 4.0.4.1 / MD 2.6 RC1 / Mono 2.10.3_5. I've now upgraded to MT 4.1 / MD 2.6 RC2 / Mono 2.10.4. The apps still build ok for the Simulator but I get exceptions when attempting to do a release build for the iPhone. Please see attached stack trace output.
Comment 1 Sebastien Pouliot 2011-08-23 16:35:33 UTC
This looks like a duplicate of #346 [1] where 'gcc-4.2' is not available anymore.
Is it possible you updated to iOS5 beta 6 ?

[1] http://bugzilla.xamarin.com/show_bug.cgi?id=346
Comment 2 Ken Budris 2011-08-23 17:27:18 UTC
Yes, I'm running iOS5 beta 6.
Comment 3 Sebastien Pouliot 2011-08-23 17:34:49 UTC
When did you update (relative to MT/MD/Mono) ?

Did you try the workaround from #346 (comment #7) ? 

Here it is again:

cp /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc-4.2

and did it work ? 

Newer release will try gcc if gcc-4.2 is not available - but I'd like to be sure this is the same issue (i.e. coming from the update to iOS5 beta 6). Thanks!
Comment 4 Ken Budris 2011-08-24 08:23:47 UTC
Copying gcc fixed the problem. This is the same issue as #346. Thank you!

*** This bug has been marked as a duplicate of bug 346 ***