Bug 3696 - Application is not re-deployed unless it is recompiled.
Summary: Application is not re-deployed unless it is recompiled.
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-02-29 17:27 UTC by Eric Beisecker
Modified: 2012-06-26 18:07 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Eric Beisecker 2012-02-29 17:27:04 UTC
Scenario: After compiling and deploying to an iOS device, if the MonoTouch application is removed from the iOS device, the next time a user clicks 'Run' or 'Debug' in MonoDevelop the application is NOT launched and the message 'Could not find application 'AppName' on device 'DeviceName' is shown in the Application Output.

If the application is not on the device MonoTouch should redeploy it.

Steps:
1. Build / Deploy a MonoTouch app to an iOS Device
2. Remove the application from the iOS device
3. Click 'Run' or 'Debug' to re-launch the application on the Device. 


Version:
MonoDevelop 2.8.6.5
Monotouch: 5.2.6
Comment 1 Mikayla Hutchinson [MSFT] 2012-02-29 19:42:55 UTC
Uploading can be quite slow, so this would hurt the experience for most users. We can't do this unless mtouch can detect and report whether the app is on the device.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2012-03-14 09:55:41 UTC
mtouch can now check if an app is installed.

mtouch --isappinstalled bundleId

returns 0 if installed, 1 if not.
Comment 3 Miguel de Icaza [MSFT] 2012-04-24 12:26:09 UTC
Probing if the app is installed is also slow.

On my machine, on first run it takes about 5 seconds to start.

On warm setups, it takes 1.29 seconds.

What I suggest is that we make it so that we proceed with the execution path as we have it now, and if we fail, only then we probe for the app being there, if it is, we report the problem to the user.   Otherwise, we upload, and retry the process.

At least in this way, not everyone has to pay the 1.2 seconds to probe on cold/ warm starts,
Comment 4 Jeffrey Stedfast 2012-06-26 18:07:18 UTC
implemented in git master