Bug 36943 - Report VBox errors when device fails to initialize
Summary: Report VBox errors when device fails to initialize
Status: NEW
Alias: None
Product: Xamarin Android Player
Classification: Xamarin
Component: Player ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-13 05:36 UTC by Richard Baverstock
Modified: 2015-12-13 05:36 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 36943 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Richard Baverstock 2015-12-13 05:36:39 UTC
I was having an issue where the device failed to initialize. The XAP error message pointed me to the virtualbox logs, which didn't really have any more useful information at first glance. 

However, when I tried to start the virtual machine directly from virtualbox, virtualbox provided a very useful error message (VT-x was not enabled in the bios). 

From a user experience point of view, it would be better if XAP could show these errors immediately to the user rather than searching through the log or having to start the virtualmachine manually. It might also be prudent for XAP to check if the bios has VT-x enabled, just like virtualbox does, to provide a more useful error message in this particular case. 

You should be able to reproduce my particular issue by disabling VT-x in your bios and trying to start a device in XAP.