Bug 36733 - Can not use certain custom controls when XAMLCompile is used
Summary: Can not use certain custom controls when XAMLCompile is used
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 2.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-08 22:33 UTC by Cody Beyer (MSFT)
Modified: 2016-12-22 22:33 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Cody Beyer (MSFT) 2015-12-08 22:33:11 UTC
### Description

The following sample demonstrates an issue where custom controls are defined inline in XAML, and they do not display correctly when XAMLCompile is used

### Sample

https://www.dropbox.com/s/rq95befaretbwnz/Xamarin4Issues-master.zip?dl=0

### Steps to Reproduce

1. Download sample
2. Set XamlCompileIssue.iOS as start-up project
3. Open XamarinCompileIssue/View/CustomerControl.xaml
4. Run on iOS
5. Notice running app on device/emulator
6. Stop running
7. Comment out lines 20-26 of XamarinCompileIssue/View/CustomerControl.xaml
6. Uncomment line 30 of XamarinCompileIssue/View/CustomerControl.xaml
8. Run on iOS

### Expected Results

Steps 8 and 4 should have the same results, a screen with a series of tabs across the top

### Actual Results

Step 4 produces a blank screen

### Versions

=== Xamarin Studio ===

Version 5.10.2 (build 26)
Installation UUID: 9896401f-d610-4967-a815-13e30f20b910
Runtime:
	Mono 4.2.1 (explicit/39edf24)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010124

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 6.0.0.41 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.2 (9548)
Build 7C68

=== Xamarin.iOS ===

Version: 9.2.2.29 (Business Edition)
Hash: 97af501
Branch: master
Build date: 2015-12-04 18:59:51-0500

=== Xamarin.Mac ===

Version: 2.4.0.112 (Business Edition)

=== Build Information ===

Release ID: 510020026
Git revision: 33a8642aa88f9119949cce312b9186308d8ca76c
Build date: 2015-12-07 17:21:45-05
Xamarin addins: af8ffe5b187898ec2f2f0c78de1bd01ae39b2008
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.2
Darwin Codys-MacBook-Pro.local 15.2.0 Darwin Kernel Version 15.2.0
    Fri Nov 13 19:56:56 PST 2015
    root:xnu-3248.20.55~2/RELEASE_X86_64 x86_64
Comment 1 Chris King 2016-12-22 22:33:49 UTC
Fixed on master