Bug 36597 - MasterDetail.Detail Icons don't appear in Toolbar while in Landscape on Tablets
Summary: MasterDetail.Detail Icons don't appear in Toolbar while in Landscape on Tablets
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-04 14:19 UTC by John Miller [MSFT]
Modified: 2015-12-07 03:32 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2015-12-04 14:19:03 UTC
**Overview:**

   Toolbar icons are not appearing when in Landscape orientation for Tablets on Android in a MasterDetail.Detail page. 

**Steps to Reproduce:**

   1. Run the attached sample on an Android tablet simulator/device.
   2. Rotate to Landscape

**Actual Results:**
   
   The icons don't appear in the toolbar area in landscape.
   See attached screenshot.    

**Expected Results:**

   The icons should appear.

**Build Date & Platform:**

   XF 2.0
   Android API 19

**Additional Information:**

   Works as expected on phones.
   Works OK on iOS.
Comment 6 Fulvio 2015-12-07 03:16:28 UTC
I’ve tested the Xamarin.Forms and Xamarin.Forms.Maps.6492-pre1 release and can confirm that it fixes the icons not appearing in Landscape.

Although, I’m afraid is hasn’t fixed the rendering issues with the TabbedPage (e.g. the Search control appearing over the map and the ListView, etc controls not working).

This is the *primary issue* that was mentioned in the following thread:

https://forums.xamarin.com/discussion/56663/adding-google-map-to-masterdetailpage-causes-rendering-issues

Is this something that the engineers are still looking into for a fix?
Comment 7 Fulvio 2015-12-07 03:18:06 UTC
When adding a ContentPage() it renders the controls fine:

this.Detail = new NavigationPage (new ContentPage { Title = "Map" }) { Title = "Map" }; 

However, when you add the MapPage() in the demo application, it doesn't render them properly:

this.Detail = new NavigationPage (new MapPage { Title = "Map" }) { Title = "Map" }; 

This was in the demo application also.
Comment 8 Paul DiPietro [MSFT] 2015-12-07 03:27:02 UTC
I think it may be best to file this as a separate bug, if you don't mind.
Comment 9 Fulvio 2015-12-07 03:27:42 UTC
Sure, I'll do that now.
Comment 10 Fulvio 2015-12-07 03:32:54 UTC
Bug submitted: https://bugzilla.xamarin.com/show_bug.cgi?id=36662