Bug 36544 - Error storyboard, can not build
Summary: Error storyboard, can not build
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 9.1 (iOS 9.1)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-03 16:57 UTC by Albilaga Linggra Pradana
Modified: 2015-12-03 17:50 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
storyboard (17.86 KB, application/xml)
2015-12-03 16:58 UTC, Albilaga Linggra Pradana
Details
diagnostic build log (362.23 KB, text/plain)
2015-12-03 17:35 UTC, Albilaga Linggra Pradana
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Albilaga Linggra Pradana 2015-12-03 16:57:20 UTC
I have a storyboard. I don't know what is error with this storyboard. I am checking it with xcode interface builder and it just showing warning message and not error message. Whenever I build it in xamarin studio in Mac OS X with latest XCode 7.1.1 it show build error and the error is in the storyboard
Comment 1 Albilaga Linggra Pradana 2015-12-03 16:58:33 UTC
Created attachment 14103 [details]
storyboard
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-12-03 17:27:28 UTC
Please attach the build log with the error as well.
Comment 3 Albilaga Linggra Pradana 2015-12-03 17:35:05 UTC
Created attachment 14104 [details]
diagnostic build log

Is this correct?
Comment 4 Rolf Bjarne Kvinge [MSFT] 2015-12-03 17:40:52 UTC
Running the ibtool command manually from a terminal yields this:

> ibtool --errors --warnings --notices --output-format human-readable-text --minimum-deployment-target 8.0 --target-device iphone --target-device ipad --auto-activate-custom-fonts --sdk /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator9.1.sdk --compilation-directory /Users/rolf/test/ibtool foo.storyboard 
/* com.apple.ibtool.document.errors */
> /Users/rolf/test/foo.storyboard:18: error: UIStackView before iOS 9.0 [6]
> /Users/rolf/test/foo.storyboard:32: error: UIStackView before iOS 9.0 [6]

So it looks like you're using classes not available in your deployment target.
Comment 5 Albilaga Linggra Pradana 2015-12-03 17:50:01 UTC
ok, thanks. hopefully xamarin provide better clear log