Bug 36537 - Building a xamarin.ios solution with MS build only (without visual studio installation) fails
Summary: Building a xamarin.ios solution with MS build only (without visual studio ins...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-03 15:56 UTC by Sebastien Van Bruaene
Modified: 2016-05-18 14:37 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sebastien Van Bruaene 2015-12-03 15:56:40 UTC
I installed xamarin.ios on our build server. My goal is not to install visual studio on this machine and only use msbuild as I do for all my build server projects. However the xamarin.ios build has a dependency on following msbuild targets file:

C:\Program Files (x86)\MSBuild\14.0\Microsoft.Common.Targets\ImportAfter\Xamarin.Common.targets

This file seems to be installed by the xamarin visual studio plugin installer only. It should be installed by the xamarin.ios installer instead.

Best regards,

Sebastien
Comment 1 Jose Gallardo 2016-05-18 14:37:43 UTC
Hi Sebastien,

You should be able to use our msi and install the Xamarin.iOS SDK but not any VS plugin, and build successfully from the command line.

There were already some improvements on that experience, and this scenario should be supported in our current stable build (XVS 4.0.4).

I'm marking the bug as resolved, but please feel free to reopen it if you're still facing issues on this scenario, and share your environment info and a diagnostic build output.

Thanks!