Bug 3649 - Pixbuf fails to load embedded resource in MonoDevelop on Windows
Summary: Pixbuf fails to load embedded resource in MonoDevelop on Windows
Status: NEW
Alias: None
Product: Gtk#
Classification: Mono
Component: gtk-sharp ()
Version: 2.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-02-26 07:43 UTC by cmre99
Modified: 2012-02-26 07:43 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 3649 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description cmre99 2012-02-26 07:43:18 UTC
Create an app with a main Gtk.Window.
In the project options set the default namespace.
Add an ico file to a sub-folder within the project and set the build action to embedded resource.
In the main window ctor use this line:

this.Icon = new Gdk.Pixbuf(null, "defaultNamespace.subfolder.iconName.ico");

Using MonoDevelop on OSX this code works.
Using VS 2008 on Windows this code works
Using MonoDevelop on Windows the PixBuf throws an "Invalid Parameter" exception

Note that the same solution/project was used for the VS2008 and MonoDevelop tests on the Windows box.