Bug 36404 - When deploying to device, i'm getting 'Could not load file or assembly....' err
Summary: When deploying to device, i'm getting 'Could not load file or assembly....' err
Status: RESOLVED INVALID
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.0.0
Hardware: Macintosh Mac OS
: --- critical
Target Milestone: ---
Assignee: Craig Dunn
URL:
Depends on:
Blocks:
 
Reported: 2015-12-01 03:29 UTC by bryan costanich
Modified: 2015-12-03 04:14 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description bryan costanich 2015-12-01 03:29:40 UTC
I have a forms app called scriptboard. I can deploy it to the simulator just fine and run it, but when i deploy it to a device (iPad), i get the error: "Could not load file or assembly 'ScriptBoard' or one of its dependencies" upon launch when it tries to load the Xaml for the main view.

let me know who needs access to the app's repo.

thanks!
Comment 2 Jason Smith [MSFT] 2015-12-02 21:24:19 UTC
xmlns:Local="clr-namespace:ScriptBoard"

don't specify the assembly, dynamic loading wont work on iOS. You do this in 3 locations.
Comment 3 bryan costanich 2015-12-03 04:14:26 UTC
craig; can you do a sweep and make sure that we don't have this in any samples in docs, please? i'm pretty sure i got the syntax from there (pretty sure this used to work because i have it in some older app code too).