Bug 36159 - FileNotFoundException when switching between iPhone and iPhoneSimulator
Summary: FileNotFoundException when switching between iPhone and iPhoneSimulator
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.0.0 (C6)
Hardware: Macintosh Windows
: --- normal
Target Milestone: 4.0.1 (C6SR1)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-23 14:04 UTC by Alexandre Pepin
Modified: 2015-12-01 20:52 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample (33.76 KB, application/zip)
2015-11-23 14:04 UTC, Alexandre Pepin
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alexandre Pepin 2015-11-23 14:04:06 UTC
Created attachment 13936 [details]
Sample

I have a FileNotFoundException during the build on an image in a referenced project when switching between iPhone and iPhoneSimulator

To reproduce :
1. Launch the "iPadTests" on an iPhone with the "iPhone" configuration selected
2. Stop the app
3. Switch to the "iPhoneSimulator" configuration
4. Launch the app on a simulator and you'll get the exception

Workaround :
We need to rebuild the project when switching between iPhone and iPhoneSimulator
Comment 2 Adrian Alonso 2015-12-01 20:52:16 UTC
Hi Alexandre, thanks for filling the bug. We already fixed this issue and the fix should be part of the next service release. Thanks, Adrian