Bug 36132 - Could not AOT the assembly
Summary: Could not AOT the assembly
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler ()
Version: XI 9.3 (xcode 7.1 previews)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2015-11-22 08:55 UTC by support
Modified: 2016-03-10 16:54 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
System info (975 bytes, text/plain)
2015-11-26 07:32 UTC, support
Details
Build log (31.95 KB, text/plain)
2015-11-26 07:34 UTC, support
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description support 2015-11-22 08:55:00 UTC
Hi,

when using a space in the Assembly name (build -> output -> Assembly Name) compiler generates an error MT3001, could not AOT the assembly "path/to/assembly/with/spaces"
Comment 1 support 2015-11-22 08:56:34 UTC
I forgot to say that I'm using latest Xamarin preview for TVOS. Removing the space makes the problem disappear.
Comment 2 Sebastien Pouliot 2015-11-22 10:35:02 UTC
That might have been a short lived issue (in the preview build) because it's part of our test suite. OTOH maybe you're hitting a special condition (that our tests do not) or the AOT error could be unrelated to the space (coincidence).

Please attach the full build log (and add "-v -v -v -v" to the Additional mtouch arguments) and also all the version information about your software stack.

The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).
Comment 3 support 2015-11-26 07:32:36 UTC
Created attachment 14004 [details]
System info

System info
Comment 4 support 2015-11-26 07:34:04 UTC
Created attachment 14005 [details]
Build log
Comment 5 support 2015-11-26 07:34:42 UTC
Added build log and system info.

To reproduce, just create a new project and change the assembly name to something with spaces.
Comment 6 Sebastien Pouliot 2016-03-10 16:54:17 UTC
Works fine for me. Closing for QA verification on C7.