Bug 3611 - MonoMac currently doesn't support bundling nibs from referenced projects and dlls
Summary: MonoMac currently doesn't support bundling nibs from referenced projects and ...
Status: RESOLVED FIXED
Alias: None
Product: MonoMac
Classification: Desktop
Component: Bindings ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
: 5309 ()
Depends on:
Blocks:
 
Reported: 2012-02-23 10:57 UTC by Chris Hamons
Modified: 2012-11-28 09:53 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Example of Problem under MonoMac (4.86 MB, application/octet-stream)
2012-02-23 11:02 UTC, Chris Hamons
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Chris Hamons 2012-02-23 10:57:28 UTC
According to this bug: https://bugzilla.xamarin.com/show_bug.cgi?id=3591 

"MonoMac currently doesn't support bundling nibs from referenced projects and
dlls"

See attached project for an example.
Comment 1 Chris Hamons 2012-02-23 11:02:19 UTC
Created attachment 1412 [details]
Example of Problem under MonoMac
Comment 2 Jeffrey Stedfast 2012-06-06 12:17:17 UTC
*** Bug 5309 has been marked as a duplicate of this bug. ***
Comment 3 Jeffrey Stedfast 2012-08-08 15:50:35 UTC
This should (mostly?) work now, although we still need to strip out the embedded resources once we extract them...
Comment 4 Jeffrey Stedfast 2012-11-16 17:11:25 UTC
This was already implemented - I think it's in MonoDevelop 3.0.5

If not, try the latest build from git master (will be 3.0.6): http://files.xamarin.com/~jeff/MonoDevelop-858ac26fd4a9c686afc150684cc8e5eb7a1b4e32.dmg

Actually, git master has a bunch of MonoMac-related fixes for building/signing
Comment 5 Martin Baulig 2012-11-28 07:47:00 UTC
Just tried this with MonoDevelop master commit 6176add / monomac commit 344cf55 and it's not working for me.

Test app:
https://github.com/baulig/Provcon-Faust/tree/027be7ac05a9d2ac8d2a468f40e4bf13fbe5708b/TestMac

This is the contents of the app after compiling:

=====
[martin@nathan:TestMac]$ find bin/Debug/TestMac.app
bin/Debug/TestMac.app
bin/Debug/TestMac.app/Contents
bin/Debug/TestMac.app/Contents/Info.plist
bin/Debug/TestMac.app/Contents/MacOS
bin/Debug/TestMac.app/Contents/MacOS/TestMac
bin/Debug/TestMac.app/Contents/MonoBundle
bin/Debug/TestMac.app/Contents/MonoBundle/Library.dll
bin/Debug/TestMac.app/Contents/MonoBundle/Library.dll.mdb
bin/Debug/TestMac.app/Contents/MonoBundle/MonoMac.dll
bin/Debug/TestMac.app/Contents/MonoBundle/MonoMac.dll.mdb
bin/Debug/TestMac.app/Contents/MonoBundle/TestMac.exe
bin/Debug/TestMac.app/Contents/MonoBundle/TestMac.exe.mdb
bin/Debug/TestMac.app/Contents/Resources
bin/Debug/TestMac.app/Contents/Resources/MainMenu.nib
bin/Debug/TestMac.app/Contents/Resources/MainWindow.nib
bin/Debug/TestMac.app/Contents/Resources/Neptune.jpg
=====

Maybe we should also add a "MonoMac Library Project" template.  I created a new MonoMac Project, deleted all the generated files, then changed the project type to Library.

There's also a question on stackoverflow about this:
http://stackoverflow.com/questions/13499884/monomac-move-ui-files-to-class-library
Comment 6 Jeffrey Stedfast 2012-11-28 09:53:03 UTC
fixed in git master. it was looking for Library.dll in the wrong location