Bug 36076 - Menu Resource Not Found If Using Upper Case Character
Summary: Menu Resource Not Found If Using Upper Case Character
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 6.0.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-11-19 20:55 UTC by Ooi Keng Siang
Modified: 2017-06-28 11:53 UTC (History)
7 users (show)

Tags: BZCU
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Ooi Keng Siang 2015-11-19 20:55:58 UTC
If I created a menu resources with mixed upper case and lower case characters, then I refer them in other code, the upper case will cause compilation not found. While this doesn't happen in id resource if I use mixed case.
Comment 1 Al Clark [MSFT] 2015-11-24 08:42:02 UTC
Hi Ooi

Would it be possible to provide your full version information there please?

Xamarin Studio in Windows
"Help -> About -> Show Details -> Copy Information [button]"

Visual Studio
"Help -> About Microsoft Visual Studio -> Copy Info [button]"

Xamarin Studio in OS X
"Xamarin Studio -> About Xamarin Studio -> Show Details -> Copy Information [button]"

Also, if you could provide a sample that exhibits the problem that would be great.

Kind regards,
Alan
Comment 2 Adam Hartley [MSFT] 2017-06-28 11:53:04 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!