Bug 36025 - Newest Provisioning Profile not selected when set to automatic
Summary: Newest Provisioning Profile not selected when set to automatic
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 9.2
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-18 15:30 UTC by Jon Dick
Modified: 2015-11-20 10:16 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jon Dick 2015-11-18 15:30:43 UTC
When I have multiple provisioning profiles that match a given project, I can see their creation timestamps in xamarin studio project settings, however if I choose automatic profile selection, building with mdtool from command line to create a .ipa package does not seem to choose the 'newest' provisioning profile that matches.

Could we please have mdtool always pick the newest one available from the matching profiles?
Comment 1 Jeffrey Stedfast 2015-11-18 16:51:06 UTC
fixed in git master
Comment 2 Jon Dick 2015-11-19 09:23:32 UTC
I just tested deleting all older profiles so there is only one possible one to pick from, however if I don't open the .sln file in XS and just run `mdtool build -c:\"Ad-Hoc|iPhone\" -p:MyProject ../../MySolution.sln"` it doesn't seem to pick the single profile at all.  So I think the sorting by CreationDate may only be half of the problem.
Comment 3 Jeffrey Stedfast 2015-11-19 13:06:21 UTC
If there's only 1 provisioning profile then it won't get sorted because there will be no need.

I don't understand how it could pick the wrong one if there's only 1 to choose from?
Comment 4 Jon Dick 2015-11-20 10:16:28 UTC
My mistake, it was picking up an AppStore profile instead of adhoc, and I thought it was failing to pick up/sign at all.  The sorting should do nicely, thanks :)