Bug 36010 - IOS Doesn't build with Xamarin.Forms V2 when targeting a physical device
Summary: IOS Doesn't build with Xamarin.Forms V2 when targeting a physical device
Status: RESOLVED INVALID
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-18 11:14 UTC by FieldstrikeMobile
Modified: 2016-02-10 17:14 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description FieldstrikeMobile 2015-11-18 11:14:33 UTC
Keeps throwing a build error of:

Error Failed to resolve "Xamarin.Forms.ImageSource Xamarin.Forms.ImageSource::FromResource(System.String)" reference from "Xamarin.Forms.Core, Version=1.5.0.0, Culture=neutral, PublicKeyToken=null" MyApp.iOS
Comment 1 Paul DiPietro [MSFT] 2015-11-18 11:57:48 UTC
Could you possibly provide a reproduction and any other pertinent information?
Comment 2 FieldstrikeMobile 2015-11-19 04:50:45 UTC
Doing a clean and rebuild seems to have fixed the error:

Although I have a strong feeling something has happened to ImageSource.FromResource that may need investigating.

I don't know if you have access to Syncfusion Datagrid but if you use this with Xamarin.Forms V2 It throws a missing method exception on Android.

Missing method ImageSource.FromResource.

I'm going to close this particular issue for now
Comment 3 FieldstrikeMobile 2015-11-20 06:02:15 UTC
I checked with Syncfusion and the Android bug mentioned here is due to their datagrid referencing Forms V1.5.1 and the descrepency in the ImageSource class

They have now clarified this so this bug is invalid
Comment 4 Harikrishnan 2016-01-27 12:01:41 UTC
Hi @FieldStrikeMobile,

I would like clarify that this is not a Syncfusion bug. 
In DataGrid control we have used ImageSource in the business logics. Since your reported version of Syncfusion controls supports 1.5.1 version of Xamarin, upgrading your sample to XF 2.0 lead to the issue. 

This could even be reproduced in a simple scenario and has already been reported here.
https://bugzilla.xamarin.com/show_bug.cgi?id=37372 

Xamarin suggest making sure that the versions of Forms are aligned correctly in order to avoid potential issues, hence this is a Xamarin issue.
Comment 5 Paul Mace 2016-02-10 17:14:35 UTC
Worth noting: In Forms 1.5.1.6471 this compiles but crashes the app; in 2.0.1.6505 the compiler catches it and it will not build, as noted at the top.