Bug 35961 - Touch task (msbuild) is broken
Summary: Touch task (msbuild) is broken
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Adrian Alonso
URL:
: 36213 ()
Depends on:
Blocks:
 
Reported: 2015-11-17 18:06 UTC by Jeff Siemens
Modified: 2015-12-07 18:25 UTC (History)
10 users (show)

Tags: _XVSSR0
Is this bug a regression?: ---
Last known good build:


Attachments
Sample project to reproduce the bug (14.23 KB, application/x-zip-compressed)
2015-11-17 18:07 UTC, Jeff Siemens
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jeff Siemens 2015-11-17 18:06:42 UTC
The touch task in MSBuild (Xamarin build?) fails in Xamarin 4 from Visual Studio with a null reference  exception.

eg. 

  <Target Name="AfterBuild">
    <Touch Files="$(ProjectDir)Info.plist" /> <!-- Fail -->
  </Target>

Sample project attached.
Comment 1 Jeff Siemens 2015-11-17 18:07:10 UTC
Created attachment 13852 [details]
Sample project to reproduce the bug
Comment 2 Jeff Siemens 2015-11-17 18:09:55 UTC
Works fine for Android and on the Mac using Xamarin Studio (iOS project).
Comment 4 Jose Gallardo 2015-11-26 08:35:45 UTC
*** Bug 36213 has been marked as a duplicate of this bug. ***
Comment 5 xamarin-release-manager 2015-11-26 10:40:23 UTC
Fixed in version 4.0.1.1 (cycle6)

Author: Adrian Alonso
Commit: c02d99be519d22ff17a4f5a3cab3dbc6a2628bd2 (xamarin/XamarinVS)
Comment 6 Udham Singh 2015-12-07 18:25:15 UTC
I have checked this issue with the help of sample app attached in comment 1 and observed that this issue has been fixed with master lane build Xamarin.VisualStudio_99.0.0.823_f987ebe707d3d896f5ba81a3df8e6d8a7f887987 as well as Cycle 6 lane build Xamarin.VisualStudio_4.0.1.32_944b6bd561b9fb4a00fc1483087905824ee7ff92

To verify this issue first I have reproduce this with latest stable builds Xamarin.VisualStudio_4.0.0.1697_deffc90178ade48ce187f727842435b09eba06af + monotouch-9.2.1.54-1

As this is working fine with latest master and cycle 6 lane builds, hence I am closing this issue.

Environment Info : 

Windows : https://gist.github.com/Udham1/3bb561b52413c8551798
Mac : https://gist.github.com/Udham1/6b43ef37321242df82ee