Bug 35906 - Assembly.ExportedTypes triggers fatal error from mono_class_from_mono_type
Summary: Assembly.ExportedTypes triggers fatal error from mono_class_from_mono_type
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: Reflection ()
Version: 4.2.0 (C6)
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Aleksey Kliger
URL:
Depends on:
Blocks:
 
Reported: 2015-11-16 16:16 UTC by Nate McMaster
Modified: 2015-11-30 23:38 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Nate McMaster 2015-11-16 16:16:16 UTC
Calling Assembly.ExportedTypes throws

mono_class_from_mono_type: implement me 0x00

* Assertion: should not be reached at class.c:6523

Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes (System.Reflection.Assembly,bool) <0xffffffff>
  at System.Reflection.Assembly.GetExportedTypes () <0x00019>
  at System.Reflection.Assembly.get_ExportedTypes () <0x00013>
  at Xunit.Sdk.ReflectionAssemblyInfo.GetTypes (bool) <0x00035>

Native stacktrace:

	mono() [0x49cf0c]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0x10340) [0x7fc9f12e0340]
	/lib/x86_64-linux-gnu/libc.so.6(gsignal+0x39) [0x7fc9f0f41cc9]
	/lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7fc9f0f450d8]
	mono() [0x62a329]
	mono() [0x62a537]
	mono() [0x62a686]
	mono(mono_class_from_mono_type+0x37) [0x517ba7]
	mono(mono_type_get_object+0x16) [0x5ba6a6]
	mono() [0x532278]
	mono() [0x5336d8]
	[0x404e82a1]


On Ubuntu 14
Mono JIT compiler version 4.2.1 (Stable 4.2.1.102/6dd2d0d Thu Nov 12 09:52:44 UTC 2015)
Comment 1 Rodrigo Kumpera 2015-11-19 14:15:49 UTC
Hey Nate,

Could you provide us with a test case?
Comment 2 Nate McMaster 2015-11-30 23:38:36 UTC
It was a weird bug in Xunit's discovery. I can't reproduce anymore.