Bug 35903 - Build hangs in XI 9.3 Preview 2
Summary: Build hangs in XI 9.3 Preview 2
Status: RESOLVED DUPLICATE of bug 35864
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: XI 9.3 (xcode 7.1 previews)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-16 15:46 UTC by David Hathaway
Modified: 2015-12-02 21:27 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
FULL BUILD LOG (32.28 KB, text/plain)
2015-11-25 00:14 UTC, David Hathaway
Details
ASM ONLY (64.42 KB, text/plain)
2015-11-25 00:15 UTC, David Hathaway
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 35864

Description David Hathaway 2015-11-16 15:46:46 UTC
Customer reports that app can build in tvOS preview 1, but in preview 2, the exact same build hangs.
Comment 11 David Hathaway 2015-12-02 21:27:49 UTC
Closing this bug.  The original bug was that bitcode was not being generated.  After installing the package from https://bugzilla.xamarin.com/show_bug.cgi?id=35864#c8, and the customer removed System.Net.NetworkInformation, as well as removing some other dependencies that didn't contain bitcode, the app now compiles and generates bitcode.

Will log a separate issue regarding System.Net.NetworkInformation LLVM exceptions if needed.

*** This bug has been marked as a duplicate of bug 35864 ***