Bug 35895 - ACTool task failed unexpectedly Could not find a part of the path
Summary: ACTool task failed unexpectedly Could not find a part of the path
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.0.0 (C6)
Hardware: PC Mac OS
: --- normal
Target Milestone: 4.0.1 (C6SR1)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-16 12:07 UTC by John Miller [MSFT]
Modified: 2015-11-25 10:03 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2015-11-16 12:07:42 UTC
**Overview:**

   Similar to #34070

   While trying to build an iOS project, an unexpected error is occurring for files that are not used in the project. 

**Steps to Reproduce:**

   Unknown. However, the customer having this issue can reproduce. 

**Actual Results:**

   Error 15 The "ACTool" task failed unexpectedly. Xamarin.Messaging.Exceptions.MessagingRemoteException: An error occured on client Build4001686 while executing a reply for topic xvs/Build/4.0.0.1686/execute-task/AppNameiOS/e1e79fb/ACTool --->
System.IO.DirectoryNotFoundException: Could not find a part of the path
"/Users/jorritvenema/Library/Caches/Xamarin/mtbs/builds/AppNameiOS/e1e79fb96a09531f1842ca66497b7e0e/Resources/Images.xcassets/LaunchImage.launchimage/Contents.json".

**Expected Results:**

   No build issues. 

**Build Date & Platform:**

   Date and platform of the build in which you first encountered the bug.

**Additional Information:**

   ImageAssets are not used in the project, and they don't appear in the Solution or Project. 
   Logs are attached as private.