Bug 3581 - [New Resolver] No code completion on Attributes
Summary: [New Resolver] No code completion on Attributes
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.9.x
Hardware: Macintosh Mac OS
: Normal blocker
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-02-22 07:55 UTC by Chris Hardy [MSFT]
Modified: 2012-02-24 05:35 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Chris Hardy [MSFT] 2012-02-22 07:55:01 UTC
See video: http://screencast.com/t/knYpihS6
Comment 1 Mike Krüger 2012-02-22 08:51:05 UTC
fixed.

Which version do you use - that case should work (after the '.'), however in that context there was another bug that I fixed.
Comment 2 Chris Hardy [MSFT] 2012-02-22 11:06:58 UTC
Just grabbed c530839 from Wrench and still hitting this issue, I also get the following exception:

https://gist.github.com/9dd851c858a4e6795aee
Comment 3 Mike Krüger 2012-02-23 01:31:08 UTC
fixed the exception - btw. a use case would've bee nice. I couldn't repro one where that happend or didn't work.
Comment 4 Chris Hardy [MSFT] 2012-02-23 10:15:20 UTC
Here's a small test Mono for Android project that has the issue: http://dl.dropbox.com/u/90453/ExampleAttributeIssue.zip
Comment 5 Mike Krüger 2012-02-24 02:11:56 UTC
Works for me.

What I've done: 
http://screencast.com/t/AT9zYWZDrBx
Comment 6 Chris Hardy [MSFT] 2012-02-24 05:35:54 UTC
I just grabbed febfc160 and it works great, maybe fixing the exception managed to get it working.

Thanks Mike