Bug 35783 - [WP] Element is already the child of another element
Summary: [WP] Element is already the child of another element
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 1.5.2
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2015-11-11 10:02 UTC by John Miller [MSFT]
Modified: 2016-01-07 10:13 UTC (History)
3 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (631.36 KB, application/zip)
2015-11-11 10:02 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2015-11-11 10:02:29 UTC
Created attachment 13776 [details]
Sample Project

**Overview:**

   Similar to #33714 and making a new bug per https://bugzilla.xamarin.com/show_bug.cgi?id=33714#c8. 

**Steps to Reproduce:**

   1. Run the attached sample on WP emulator. 
   2. Press the Close button. 

**Actual Results:**

   An exception: Element is already the child of another element

**Expected Results:**

   No exceptions.

**Build Date & Platform:**

   XF 1.5.2 pre2

**Additional Information:**

   Was not able to reproduce this before, but now I can....
Comment 1 Rui Marinho 2015-12-01 22:33:10 UTC
Should be fixed in 2.0.1-pre1
Comment 2 Gerald Versluis 2016-01-02 16:30:44 UTC
It is NOT fixed in 2.0.1.6492-pre1
Comment 3 DanB 2016-01-07 10:13:35 UTC
Again, it is not fixed in 2.0.1.6492-pre1

The Sample that John attached is initialy from me.

We are waiting more than 3 months (!) for this fix, since that we are stucked on Version XF_1.4.3.6376 from 9. Juli 2015 !!

???

Please changes status to confirmed and not fixed.