Bug 35740 - RC1 Debugger with shared runtime and fast assembly enabled probably deadlocks
Summary: RC1 Debugger with shared runtime and fast assembly enabled probably deadlocks
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 6.0.99
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-10 11:28 UTC by Przemysław Raciborski
Modified: 2017-06-28 11:40 UTC (History)
6 users (show)

Tags: BZCU
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Przemysław Raciborski 2015-11-10 11:28:34 UTC
I suspect that Xamarin.Droid deadlocks when shared runtime and fast assembly mode is enabled. I get ANRs with shared runtime and fast assembly on.
Comment 1 Przemysław Raciborski 2015-11-10 11:30:42 UTC
looks like without shared runtime and fast assembly i get anrs too.. have no idea what's going on.
Comment 2 Al Clark [MSFT] 2015-11-22 14:43:18 UTC
Hi Przemysław,

Thank you for your report.  Could you please try updating to the latest stable and let me know if you still have an issue?  It's possible that this may already have been addressed.  If so then I'd be obliged if you could include the following:

1. Your full version information:

Xamarin Studio in Windows
"Help -> About -> Show Details -> Copy Information [button]"

Visual Studio
"Help -> About Microsoft Visual Studio -> Copy Info [button]"

Xamarin Studio in OS X
"Xamarin Studio -> About Xamarin Studio -> Show Details -> Copy Information [button]"

2. Your IDE logs:

In Visual Studio:
Help -> Xamarin -> Zip Logs

Xamarin for Mac logs:
You can select the "Go -> Go to Folder" menu item in Finder, and then copy and paste the path into the dialog.

~/Library/Logs/XamarinStudio-5.0

This folder can also be opened via "Help -> Open Log Directory".

Kind regards
Alan
Comment 3 Adam Hartley [MSFT] 2017-06-28 11:40:40 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!