Bug 3569 - Cannot create keybindings using special characters in Windows
Summary: Cannot create keybindings using special characters in Windows
Status: NEW
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.9.x
Hardware: PC Windows
: Low normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-02-21 18:44 UTC by Zane
Modified: 2013-09-16 17:01 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 3569 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Zane 2012-02-21 18:44:16 UTC
I tested this on Mac and Windows and the problem only occurs on Windows. This was brought to my attention by one of the md-feedback questions on desk.com. When entering the keys that you want a command to be bound with, MonoDevelop just uses the US layout character instead of the international one. I tested this on a keyboard using a Swedish layout. Instead of using the Swedish character ö, MonoDevelop just used ;, the English layout setting.
Comment 1 Cody Russell 2013-09-16 17:01:21 UTC
Hi Zane,

I've been working on input issues related to keyboard layout.  If you have a chance, could you test this build to see if it helps with your problem?

https://dl.dropboxusercontent.com/u/5179007/libgdk-win32-2.0-0.dll

Put this into C:\Program Files (x86)\GtkSharp/2.12\bin

(backup the file in that directory first, just in case)

Thanks,
   Cody