Bug 35556 - Cannot have xaml pages with same name - "Could not find a part of the path" Error
Summary: Cannot have xaml pages with same name - "Could not find a part of the path" E...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 3.11 (C5)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-04 18:24 UTC by Brad Zacher
Modified: 2016-05-18 15:51 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Brad Zacher 2015-11-04 18:24:27 UTC
Problem - cannot have two views with the same name in different namespaces - the build fails.

Workaround - rename one of the views.

Repro:

Create a blank forms app.
Create a xaml view in one namespace, say BugTest.Pages.MainPage
Create a second xaml view with the same name in another namespace, say BugTest.Pages.Other.MainPage

+ BugTest
|
+-- Pages
  |
  +-- MainPage.xaml
  |
  +-- MainPage.xaml.cs
  |
  +-- Other
    |
    +-- MainPage.xaml
    |
    +-- MainPage.xaml.cs

Attempt a build and receive the following error
Could not find a part of the path '<path>\BugReport\Pages\MainPage.xaml;Pages\Other\MainPage.xaml'.

Same as reported on the following forum post: https://forums.xamarin.com/discussion/41329/could-not-find-a-part-of-the-path
Comment 1 Jose Gallardo 2016-05-18 15:51:38 UTC
This issue should be fixed on current latest public builds.
Marking it as resolved, but please feel free to reopen it if you're still able to reproduce it with current stable/beta.

Thanks