Bug 3549 - Mouse clicks problem
Summary: Mouse clicks problem
Status: VERIFIED DUPLICATE of bug 546
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8.6
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-02-20 10:33 UTC by zaripov.rinat
Modified: 2013-06-19 09:43 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Video with mouse clicks visible (1.27 MB, video/quicktime)
2012-02-20 10:33 UTC, zaripov.rinat
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 546

Description zaripov.rinat 2012-02-20 10:33:56 UTC
Created attachment 1390 [details]
Video with mouse clicks visible

Hi All,
I've been facing this problem several times on my mac, so I decided to create bug about it. After some time using MonoDevelop it enters state when mouse clicks are ignored. This happens for one, three or more clicks from time to time. The mouse cursor hangs regardless of where the mouse points. Looks like mouse is getting "captured" by some window and clicks don't go anywhere except that window. Now you need to understand what the window is.

Restart fixes the problem.

I've recorded video of this, attaching video. Sorry, but video is mov. 

Thanks for the great product.
Comment 1 Mikayla Hutchinson [MSFT] 2012-02-21 15:38:44 UTC
This should be fixed by the version of GTK+ that's in Mono 2.10.9.

*** This bug has been marked as a duplicate of bug 546 ***
Comment 2 Mohit Kheterpal 2013-06-19 09:43:48 UTC
Today we have checked this issue on following builds :

XS 4.0.9 (build 3)
MT 6.3.6.76
Mono 3.0.11

Now we are able to expand and close solution tree.

Hence closing this issue. Changing its status to verified.