Bug 35398 - [Master] Getting exception on running Xamarin.Mac "MacOutlines" sample application.
Summary: [Master] Getting exception on running Xamarin.Mac "MacOutlines" sample applic...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Runtime ()
Version: Master
Hardware: PC Mac OS
: High major
Target Milestone: master
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-10-30 09:44 UTC by Rajneesh Kumar
Modified: 2015-11-02 10:01 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Chris Hamons 2015-10-30 11:44:47 UTC
This is because we're "fixing" our mistake. We have two methods:

ViewForTableColumn
GetView

You have to pick one. Your sample has two. You'll need to remove one.

Before this, GetView was the only one working (ViewForTableColumn was broken).
Comment 2 Chris Hamons 2015-10-30 12:35:55 UTC
Actually, let me dig more. This might be something else.
Comment 3 Rajneesh Kumar 2015-11-02 10:00:57 UTC
Sample Info: mac-samples1a5e12e00cd665c4d1fb6f59bb782b9a4e74bc06zip

I have checked this issue with the latest master build:
xamarin.mac-2.5.0.2016_4fff415c42da39b17e86bcf32d2379103d493e57

So as per discussion with Chris, I replace method name "ViewForTableColumn" via "GetView" and after that I am able to build and run the application successfully without any exception, and getting the expected behavior as mentioned in the bug description.

Screencast: http://www.screencast.com/t/E7VyO1sN2LV

This issue has been fixed in master build, and working fine. Hence I am closing this issue.


Thanks..!