Bug 35224 - Missing binding of ALAssetPropertyLocation
Summary: Missing binding of ALAssetPropertyLocation
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 9.4 (iOS 9.2)
Hardware: All All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-10-23 17:11 UTC by Alma Jensen
Modified: 2015-10-24 10:23 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Alma Jensen 2015-10-23 17:11:06 UTC
I can't find 
ALAssetPropertyLocation

in Xamarin Studio for iOS.  I'm trying to use it when trying to read Exif data off of an image in iOS.  
referencing this me and another developer can't seem to find a binding for it.
http://developer.xamarin.com/api/namespace/MonoTouch.AssetsLibrary/
Comment 1 Sebastien Pouliot 2015-10-24 10:23:41 UTC
It is mapped to the `ALAsset.Location` property.

It returns the `CLLocation` using the `ALAssetPropertyLocation` key.