Bug 35122 - ListView scrolling problem on Android M (Empty padding)
Summary: ListView scrolling problem on Android M (Empty padding)
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.5.2
Hardware: PC Mac OS
: Normal blocker
Target Milestone: ---
Assignee: Rui Marinho
URL:
: 35863 ()
Depends on:
Blocks:
 
Reported: 2015-10-20 20:16 UTC by Pete Schmitz
Modified: 2016-07-26 21:27 UTC (History)
10 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin project that reproduces the issue (1.91 MB, application/zip)
2015-10-21 14:14 UTC, Pete Schmitz
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Pete Schmitz 2015-10-20 20:16:43 UTC
Xamarin Studio 5.9.7
Xamarin Forms 1.5.1.6471

List views on devices running Android M appear to have extra padding surrounding the list view content. Here's a video that displays the problem:

https://youtu.be/220DiPyJfDQ

I've attached a Xamarin project that recreates the issue when running on an Android device on M.
Comment 1 Stefan Reinhard 2015-10-21 09:45:50 UTC
We are having the same issue here. Tested on my Nexus 5 running Android 6.0
Comment 2 Pete Schmitz 2015-10-21 14:14:24 UTC
Created attachment 13481 [details]
Xamarin project that reproduces the issue

For this attachment: 
- Unzip, open in Xamarin, restore project
- Launch on a device/emulator running Android M
- Scroll the listview to see the header/footer padding
Comment 3 Tobias Schulz 2015-10-22 11:06:05 UTC
I have this bug since July:

https://forums.xamarin.com/discussion/comment/160366

And it still exists on the latest xamarin forms release.
Comment 4 Tobias Schulz 2015-10-22 11:10:48 UTC
Xamarin Forms: 1.5.1.6471
Comment 5 Pete Schmitz 2015-10-24 12:07:16 UTC
Just to clarify a bit more on this issue:

If I choose to compile targeting a lower Android API (22 or below), this bug does not exist on M devices. Additionally, this issue does not seem to exist while using an older version of forms (1.3.3.6323), even if targeting api 23.

Also, I would recommend explicitly setting an override API version for "Target Android version" if attempting to reproduce/work through this issue. "Automatic - use target framework" caused some headaches.
Comment 6 Tobias Schulz 2015-10-25 08:50:45 UTC
Any update on this bug? It makes our app quite unusable and is really annoying...
Comment 7 Jason Smith [MSFT] 2015-10-26 14:33:03 UTC
No worries, we are looking into it
Comment 8 Jason Smith [MSFT] 2015-10-28 04:58:20 UTC
Should be fixed in 1.5.2-pre2
Comment 9 Paul DiPietro [MSFT] 2015-11-14 17:45:41 UTC
*** Bug 35863 has been marked as a duplicate of this bug. ***
Comment 10 Rohit 2016-07-26 21:27:02 UTC
Any update on this issue.