Bug 3510 - Header files not showing in Interface Builder
Summary: Header files not showing in Interface Builder
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 2.8.6
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-02-17 02:58 UTC by Mark Hodgson
Modified: 2012-03-02 20:56 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
zipped project folder (4.37 MB, application/octet-stream)
2012-02-17 02:58 UTC, Mark Hodgson
Details
Screenshot of it working for me (327.39 KB, image/png)
2012-02-23 13:55 UTC, Jeffrey Stedfast
Details
log file for a MonoTouch project in MonoDevelop (1.45 KB, application/octet-stream)
2012-02-24 16:54 UTC, Chris Maka
Details
A more recent log file from a project with the missing .h file problem (1.45 KB, application/octet-stream)
2012-02-24 17:32 UTC, Chris Maka
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mark Hodgson 2012-02-17 02:58:07 UTC
Created attachment 1370 [details]
zipped project folder

After recent MonoTouch update, I cannot add oulets to my XIBs because the header files are not showing for my existing XIBs.  If I add a new view controller, it adds the header (e.g. test.xib in attached project).  Have tried clean, deleting obj, bin folder, etc.  Compared test.xib with my SettingsViewController.xib and they seem pretty much the same.

Using:
    MD 2.8.6.4
    Monotouch 5.2.4
    XCode 4.2 build 4c199
    Mac OS 10.6.8

Thanks
Comment 1 Mark Hodgson 2012-02-17 03:47:44 UTC
...update

Removing the XIB / designer / viewcontroller class from project and then re-adding  appears to restore functionality (for that view)!
Comment 2 Jeffrey Stedfast 2012-02-23 13:55:08 UTC
Created attachment 1413 [details]
Screenshot of it working for me

I just tested this using:
    MonoDevelop 2.8.6.5
    Xcode 4.2 build 4C199
    MacOS X 10.6.8

(the version of MonoTouch is irrelevant)

Works fine - I double-clicked ConversationViewController.xib and all of the header files were there.

Doesn't seem to matter what *.xib file I double-click, Xcode always has all the header files.

Attached a screenshot.
Comment 3 Jeffrey Stedfast 2012-02-23 13:58:41 UTC
How are you determining that the header files aren't there? Are you expanding the project tree (like I did in the screenshot)? Or are you clicking the Assistant Editor and it's not opening the header file?


If you are clicking the Assistant Editor, then your Xcode is probably just still indexing your source files (note the progress bar at the top of your Xcode window in the iTunes-like digital display area).
Comment 4 Jeffrey Stedfast 2012-02-24 12:44:38 UTC
The next time this happens for you, could you attach ~/Library/Logs/MonoDevelop-2.8/Xcode4Sync.log?

That might have some clues...
Comment 5 Chris Maka 2012-02-24 16:54:35 UTC
Created attachment 1419 [details]
log file for a MonoTouch project in MonoDevelop

this is the log file of a project where the .h file for the ViewController file was generated when its xib was first double-clicked and opened in Interface Builder, but is now missing when Xcode is accessed.
Comment 6 Jeffrey Stedfast 2012-02-24 17:09:36 UTC
Chris: it looks like MonoDevelop generated AppDelegate.m and AppDelegate.h, but it didn't generate any ObjC files for any backing classes (do they exist??) for MyEvents_Protocols_DelegatesViewController.xib.

Do you have a class for MyEvents_Protocols_DelegatesViewController.xib?

If so, what does it subclass?
Comment 7 Chris Maka 2012-02-24 17:32:55 UTC
Created attachment 1420 [details]
A more recent log file from a project with the missing .h file problem

A more recent log file from a project with the missing .h file problem.
Comment 8 Jeffrey Stedfast 2012-03-01 12:56:03 UTC
From information gleaned from other users, this might be a bug in the Types database.
Comment 9 Jeffrey Stedfast 2012-03-02 18:35:47 UTC
I've committed a possible "fix" for this and backported it to the 2.8.8 branch, so hopefully it'll end up in a 2.8.8.2 beta.

I have no idea if it fixes things, though, because I still cannot reproduce it.
Comment 10 Jeffrey Stedfast 2012-03-02 20:56:53 UTC
I guess I'll tentatively close this