Bug 3479 - All linked assemblies need to check for IJavaObject
Summary: All linked assemblies need to check for IJavaObject
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-02-15 14:47 UTC by Jonathan Pobst
Modified: 2012-02-15 16:47 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jonathan Pobst 2012-02-15 14:47:53 UTC
Currently there is special logic in the linker to support preserving our JNI infrastructure when linking Mono.Android.dll.

This logic needs to be extended to all assemblies, as things like Maps or 3rd party bound assemblies use this infrastructure as well.
Comment 1 Jonathan Pobst 2012-02-15 16:47:44 UTC
Fixed for 4.2.