Bug 34767 - Designer shows loading spinner forever and does not load the storyboard
Summary: Designer shows loading spinner forever and does not load the storyboard
Status: VERIFIED DUPLICATE of bug 34734
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer ()
Version: 4.0.0 (C6)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-10-12 12:16 UTC by John Miller [MSFT]
Modified: 2015-10-16 02:01 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 34734

Description John Miller [MSFT] 2015-10-12 12:16:28 UTC
**Overview:**

   A customer is unable to use the designer. When opening the storyboard file, the designer only shows the loading spinner and never loads the file. 

**Steps to Reproduce:**

   It is unclear how to reproduce this right now. I am logging this as a start to tracking the issue. 

**Actual Results:**

   Attached are the logs given so far. 

**Build Date & Platform:**

   XVS 3.11.1443.0

**Additional Information:**

   Attached is a storyboard which is said to reproduce the issue, however, it loads fine for me.
Comment 4 Alan McGovern 2015-10-12 19:29:02 UTC
They need to use the alpha versions of xamarinvs, the ones with the new mac agent. We're not going to fix anything with the old build host because it's replacement is already shipping and the replacement has dozens of fixes which could prevent this problem.
Comment 7 John Miller [MSFT] 2015-10-14 10:59:14 UTC
The customer can edit their storyboards in Xcode. 
They cannot edit them in XS in Stable or Alpha. 
They cannot edit them in VS in Stable or Alpha.

Neither a new storyboard, or their existing project storyboard are working in any Xamarin designers. They all work in Xcode.
Comment 8 Alan McGovern 2015-10-14 22:50:05 UTC
This could be fixed by this commit: https://github.com/xamarin/md-addins/commit/ee48ade5fe54e9f9e72f2ae804f465361df55a81

We'll need to get the customer newer builds to see if that patch has any impact. It's the best guess we have as we cannot reproduce this issue on any machine
Comment 9 Alan McGovern 2015-10-14 22:52:46 UTC
That change was backported a few days ago so it is in the latest internal builds
Comment 10 Alan McGovern 2015-10-15 14:10:11 UTC

*** This bug has been marked as a duplicate of bug 34734 ***
Comment 11 Saurabh 2015-10-16 02:01:34 UTC
As per https://bugzilla.xamarin.com/show_bug.cgi?id=34734#c7 changing the status to Verified.