Bug 34580 - Access method 'Xamarin.Forms.NameScope..ctor()' failed
Summary: Access method 'Xamarin.Forms.NameScope..ctor()' failed
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Stephane Delcroix
URL:
Depends on:
Blocks:
 
Reported: 2015-10-06 00:34 UTC by Adam
Modified: 2016-04-13 18:05 UTC (History)
4 users (show)

Tags: AC XAMLC WP
Is this bug a regression?: ---
Last known good build:


Attachments
Repo (193.95 KB, application/x-zip-compressed)
2015-10-06 00:34 UTC, Adam
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Adam 2015-10-06 00:34:25 UTC
Created attachment 13198 [details]
Repo

In 1.5.1-pre1 I have a very simple windows phone application as attached. When I try to run it with 

[assembly: XamlCompilation(XamlCompilationOptions.Compile)]

I get the error

Attempt by method 'Repo.ChartPage.InitializeComponent()' to access method 'Xamarin.Forms.NameScope..ctor()' failed.

If I remove the assembly attribute the application runs fine.
Comment 1 Stephane Delcroix 2015-10-06 06:59:18 UTC
Hi Adam,

I was able to reproduce this issue. It only happens on WindowsPhone. Disable XamlC for now on that project
Comment 2 Jason Smith [MSFT] 2016-04-13 18:05:17 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team