Bug 34518 - Objective-C exception in share extension - "NSGetSizeAndAlignment() unsupported type encoding spec"
Summary: Objective-C exception in share extension - "NSGetSizeAndAlignment() unsupport...
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: XI 9.0 (iOS9)
Hardware: PC Mac OS
: --- normal
Target Milestone: C6SR1
Assignee: Bugzilla
URL:
: 34194 ()
Depends on:
Blocks:
 
Reported: 2015-10-02 07:42 UTC by Adam Hartley [MSFT]
Modified: 2015-10-27 02:34 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample (3.95 MB, application/zip)
2015-10-02 07:42 UTC, Adam Hartley [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Adam Hartley [MSFT] 2015-10-02 07:42:38 UTC
Created attachment 13173 [details]
Sample

## Steps to reproduce

1. Download and run sample on the simulator
2. Close the app and open the Photos app
3. Select a few photos
4. Share the share button
5. Go to "More..." and enable "XShareExtensionTest"
6. Tap "XShareExtensionTest"
7. Tap post

You may have to do this a few times for the exception to appear.

## Expected result

No exception should be thrown.

## Actual result

Objective-C error alert on the device. See images in the attachment for details.

## Notes

Possibly related to bug 34194

=== Xamarin Studio ===

Version 5.9.7 (build 9)
Installation UUID: 11a26d86-0d21-407a-8da9-8c197ecc0ad1
Runtime:
	Mono 4.0.4 ((detached/d481017)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400040004

=== Apple Developer Tools ===

Xcode 7.0.1 (8228)
Build 7A1001

=== Xamarin.iOS ===

Version: 9.0.1.20 (Business Edition)
Hash: d8e9592
Branch: master
Build date: 2015-09-18 23:22:05-0400

=== Xamarin.Android ===

Version: 5.1.6.7 (Business Edition)
Android SDK: /Users/Adam/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.2.111 (Business Edition)

=== Build Information ===

Release ID: 509070009
Git revision: 31fa64709030b3edb971237780a452a4c69943c4
Build date: 2015-09-17 11:44:37-04
Xamarin addins: b105d33d8cd72911ff2cf3ee0b7715d37e5f19a6

=== Operating System ===

Mac OS X 10.11.0
Darwin Adams-MBP-2 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-10-05 11:28:39 UTC
Fixed.

maccore/master: 0b90b8b1b2525dbbd5c4b4f90082c29aaf8f6e2d
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-10-05 11:34:23 UTC
*** Bug 34194 has been marked as a duplicate of this bug. ***
Comment 4 Shruti 2015-10-26 04:45:03 UTC
***************************************************************************
Reproduce Status :
***************************************************************************

First, I have reproduced this issue following steps given in comment(0) with attached sample project using monotouch-9.0.1.20_d8e9592a0ebfc6e117f290feddfd583f9f57e949. I am able to reproduce this issue on 6th attempt of after tapping on Post. 
Screencast: http://www.screencast.com/t/JuII2e31GUcG


***************************************************************************
Verify Status :
***************************************************************************

I have verified this issue with latest Master monotouch-9.3.0.182_8e3d23dce2dda3f1b006d8e72ed52155559e7459. I have clicked 20 times on Post button and It is working fine on every Post.
Screencast: http://www.screencast.com/t/ZWEwY9YpmKA
Environment Info: https://gist.github.com/shrutis360/5c4bca7fcf31734c844e


I will close this issue when this issue will be fixed on C6.
Comment 5 Shruti 2015-10-27 02:34:17 UTC
This issue is working fine with C6 monotouch-9.2.1.9_ee9fa3f84b64d468dcc441b5022288145e236b67
Screencast: http://www.screencast.com/t/4rIPzpJJZO
Environment Info: https://gist.github.com/shrutis360/705e216c1afe8c748928